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Domain Menu Commands

Add Domain
Adds a domain to be monitored. Choose a domain to add in the Select Domain dialog box.

Remove Domain

Removes a selected domain from the list of monitored domains. You can also remove a selected domain
by pressing the DEL key.

Properties

Displays details about servers and trusted domains for a selected domain. You can also display the
Domain Controller Status dialog box by double-clicking the PDC (Primary Domain Controller) name in
the main Domain Monitor window.

Exit

Closes the Domain Monitor window. You can also press ALT+F4 to quit Domain Monitor.



View Menu Commands
Refresh

Queries all servers and updates the information displayed in Domain Monitor. For large networks, the
update process can take several minutes.

You can also press F5 to refresh the information displayed.



Options Menu Commands

Intervals
Displays the Intervals dialog box so that you can specify the time interval for status updates.

Monitor Trusted Domain

Specifies whether trusted domains are monitored, with the information displayed in the lower
TDCLinkStatus list. The Show Trust Domain button in the Domain Controller Status dialog box is
available only if the Monitor Trusted Domain command is checked.

Save Settings on Exit

Specifies whether the selected domains and other options in Domain Monitor are preserved between
working sessions. Choose this command to turn this feature off or on. A check mark appears by this
command name when it is active.



Select Domain Dialog Box

The Select Domain dialog box appears when you choose the Add Domain command from the Domain
menu. Use either the Domain box or Select Domain box to choose the domain you want to add.

This dialog box works the same as similar browse lists that appear throughout Windows NT.

To use the Domain box:

1 Type the name of a domain that you want to include in the list of domains to monitor, including the \\
characters for the UNC path name.

2 Choose the OK button.
To use the Select Domain box:

1 Select a domain name from the list.
2 Choose the OK button.



Domain Controller Status Dialog Box

This dialog box appears when you choose the Domain Properties command from the Domain menu.
You can also display this dialog box by double-clicking a domain name in the PDC (Primary Domain
Controller) column in the main Domain Monitor window.

Click the name of an item in the Domain Controller Status dialog box to see more information about that
item:

DC Name

DC State

DC Status

Replication Status
Connection to PDC
Link to Trusted Domain

Trusted Domain

Trusted DC

Secure Channel Status
Disconnect Button

Show Trusted DC Button



Trusted Domain Dialog Box

This dialog box appears when you choose the Show Trusted Domain button in the Domain Controller
Status dialog box.

Click the name of an item in the Trusted Domain dialog box to see more information about that item:
DC Name

DC Status

Replication Status
Connection to PDC




Intervals Dialog Box
This dialog box appears when you choose the Intervals command from the Options menu.
In the Intervals box, type the number of seconds you want to wait between status updates.

The update can take several minutes if there is a large number of servers in the specified domains or if
there is a long list of domains to be monitored.

The default is 900 seconds (15 minutes).



Using Domain Monitor

The Domain Monitor utility monitors the status of servers in a specified domain and its secure channel
status to the domain controller and to domain controllers in trusted domains. If any status shows errors,
Domain Monitor displays various status icons, plus the domain controller name and list of trusted
domains.

Domain Monitor connects to servers to retrieve status information using the current user's username and
password. So if the current user account doesn't exist in a domain or in the database of a trusted
domain, the status query may fail. Any user who is logged on can query the status information, but only
administrators can use the Disconnect button to disconnect and restore connections.

When errors occur in connections with a problem domain, you can disconnect and reconnect to attempt
to correct the error by choosing the Disconnect Button in the Domain Controller Status dialog box.

See Also

Adding and Removing Domains from the List
Viewing Domain Status
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Setting Options




Domain Status Icons

The status of a domain is shown in one of the following states:

=2 Success: Indicates that all servers in the domain are running and that Connection To PDC and
Link To Trusted Domain show only successful connections (no errors).
s Problem: Indicates a problem that may requires attention. This icon appears when any server in

the domain has an errors under Connection To PDC or Link To Trusted Domain or when any server in the
domain is down.

Warning: Indicates a severe problem that requires attention. This icon appears when the status
for any server or domain controller shows an error or when the domain's domain controller is down.

» Domain Down: This icon is displayed when all servers in the domain are down.
= Unknown: This icon is displayed while Domain Monitor is checking connections.




Adding and Removing Domains from the List

To add to the list of domains to be monitored:
L From the Domain menu, choose the Add Domain command, and then type a domain name or
select a name from the list in the Select Domain dialog box.

To remove a domain from the list of monitored domains:

L Select the domain to be removed and then press the DEL key.
Or from the Domain menu, choose the Remove Domain command.



Viewing Domain Status

To view details about a domain in the Domain Monitor window:

= Double-click the name of the domain controller in the Connection to PDC (Primary Domain
Controller) column in the Domain Monitor window.

Or select the domain for which you want to view details. Then from the Domain menu, choose the
Properties command.

In the Domain Controller Status dialog box, which shows details about the selected domain, you can
choose the Show Trusted DC button to view details about a selected trusted domain.



Viewing Trusted Domain Status

To view details about trusted domains, the Monitor Trusted Domain command must be checked on the
Options menu.

To view the status of a trusted domain:

D Select the domain name in the TDCLinkStatus list of the Domain Controller Status dialog box,
and then choose the Show Trusted Domain button.

The Trusted Domain dialog box shows the DC Status, Replication Status, and Connection To PDC for
the selected domain.

See Also

Viewing Errors Reported by Domain Monitor.



Setting Options

You can manually refresh the displayed information, set the rate for automatic refreshing, and specify
whether trusted domains are monitored.

To refresh displayed information manually:

D From the View menu, choose the Refresh command.
Or press F5.

To define the interval for automatic refreshing:
= From the Options menu, choose the Intervals command and type a number of seconds between
updates in the Intervals dialog box.

To monitor trusted domains:

= From the Options menu, choose the Monitor Trusted Domain command.

To preserve optional settings between work sessions:

= From the Options menu, choose the Save Settings on Exit command.



DC Name

Shows the name of the server for a domain.



DC State

If the icon is dimmed, that server is inactive. The icons show the type of computer for the connection:
The domain controller for the domain
A backup server for the domain.

= A down-level computer on the domain.



DC Status

Online indicates that the server is running.
Offline indicates that the power is off or that the Server service, Workstation service, or NetLogon
service is not running.



Replication Status

InSync indicates that the dates are identical for replicated information on the domain controller and the
server.

InProgress indicates that an update is currently underway.

ReplRequired indicates that the dates for replicated information on the backup server are older than for
information on the domain controller, requiring a replication update.



Connection to PDC

Shows success or any errors in the links for the Primary Domain Controller (PDC) on a selected domain.
To interpret the error numbers that appear in these lists, see the Windows NT Messages database.



Link to Trusted Domain
Shows success for the links if all the trusted domains show success in the lower list of trusted domains.
If Link to Trusted Domain shows an error, the lower list shows where and what the problem is.

The domain controller connects to only one server in the trusted domain, although several servers could
be available. The highlighted server name in the Link to Trusted Domain list shows which server is
connected.



Trusted Domain

Shows the names of the trusted domains connected to a selected domain in the upper list.



Trusted Domain Controller

Shows the name of the connecting domain controller or server for a trusted domain.

A connection is made to only one domain controller or server in the trusted domain (even though several
could be available for the connection).



Secure Channel Status

Shows the linking status between the domain controller and the trusted domain controller. If there is no
error, it shows "Success." Otherwise, it shows the error message number.

To communicate with the NetLogon service on a remote computer, the NetLogon service sets up a
secure communication channel, which is used to pass the user name and password to a Windows NT
Advanced Server during validation. Windows NT computers maintain security on these communication
channels by using user-level security to create the channel.

NetLogon service attempts to set up a secure channel when the service is started. Failing that,
NetLogon will retry every 15 minutes or whenever an action occurs that requires validation.



Disconnect Button

If an error appears in the Trusted Domain Controller (TDC) status list, select that trusted domain name,
and then choose the Disconnect button. This disconnects the selected connection and attempts to
establish a new connection.

This is helpful when a server attempts to connect to a trusted domain controller across an expensive
wide-area network (WAN) link or when the trusted domain controller is loaded heavily and responses

slowly.
You can successfully choose the Disconnect button only if you are logged on as an administrator.



Show Trusted Domain Controller Button

Choose this button to display information about the Trusted domain selected in the Domain Controller
Status dialog box. The information includes the DC Status, Replication Status, and Connection To PDC
for the selected trusted domain.

This button is only available if Monitor Trusted Domain is checked in the Options menu.



Error
To find the meaning of an error number, see Viewing Errors Reported by Domain Monitor.



Trusted Domain

A trusted domain has a linked relationship with another Windows NT Advanced Server domain. In the
trust relationship, one domain honors the users of another domain, trusting the logon authentications
performed by the other domain for its own users. User accounts and global groups defined in a trusted
domain can be granted rights, resource permissions, and local group memberships at a trusting domain
and its member computers, even though those accounts don't exist in the trusting domain's security
database.

When trust relationships are properly established between all the domains of a network, they allow a
user to have only one user account and one password in one domain, yet to access the entire network.

To establish a trust relationship between domains, use User Manager for Domains.



Viewing Errors Reported by Domain Monitor

Click an error name to see information about that error.
Or choose the Search button and type the error name to view information.

AccDeni NoBrowse NoSvc
BadPath NoBrSrv NoTrLSA
BadSvc NoDC NoTrSAM
BadTrCfg NoEnMem NotSupp
DmTrInC NoFile NoWksta
InvDmRol NolLogSrv RegNotAc
InvDmSta NoNet Success
LogFail NoSrv VCDisCn

NetBusy NoSuchDm



AccDeni

Access is denied.

BadPath

The network path was not found.

BadSvc

The service name is invalid.

BadTrCfg

The server is not configured for transactions.

DmTrinC

The name or security ID (SID) of the domain
specified is inconsistent with the trust
information for that domain.

InvDmRol

This operation is only allowed for the Primary
Domain Controller of the domain.

InvDmSta

The domain was in the wrong state
to perform the security operation.
LogFail

Logon failure: unknown user name

or bad password.

NetBusy

The network is busy.

NoBrowse

The requested information is not available.

NoBrSrv

The list of servers for this workgroup is
not currently available.

NoDC

Could not find domain controller for this domain.



NoEnMem

Not enough storage is available to
process this command.

NoFile

The system cannot find the file specified.

NoLogSrv

There are currently no logon servers
available to service the logon request.

NoNet

The workstation driver is not installed.

NoSrv

The Server service is not started.

NoSuchDm

The specified domain did not exist.

NoSvc

The service has not been started.

NoTrLSA

The workstation does not have a trust secret.

NoTrSAM

The SAM database on the Windows NT Advanced
Server does not have a computer account for this
workstation trust relationship.

NotSupp

The network request is not supported.

NoWksta

The Workstation service has not been started.

ReqNotAc

The network request was not accepted.

Success

The configuration registry database



operation completed successfully.

VCDisCn

The session was canceled.

Remove Domain

Removes a selected domain from the list of monitored domains. You can also remove a selected domain
by pressing the DEL key.



Add Domain
Adds a domain to be monitored. Choose a domain to add in the Select Domain dialog box.



Exit

Closes the Domain Monitor window. You can also press ALT+F4 to quit Domain Monitor.



Refresh

Queries all servers and updates the information displayed in Domain Monitor. For large networks, the
update process can take several minutes.

You can also press F5 to refresh the information displayed.



Intervals

Displays the Intervals dialog box so that you can specify the time interval for status updates.
See Also
Intervals dialog box



Monitor Trusted Domain

Specifies whether trusted domains are monitored, with the information displayed in the lower Link to
Trusted Domain list. The Show Trust Domain button in the Domain Controller Status dialog box is
available only if the Monitor Trusted Domain command is checked.

See Also

Domain Controller Status dialog box



Save Settings on Exit

Specifies whether the selected domains and other options in Domain Monitor are preserved between
working sessions. Choose this command to turn this feature off or on. A check mark appears by this
command name when it is active.



Contents
Starts Help and displays the topics in Domain Monitor Help.



Search for Help On

Opens the Search dialog box for Domain Monitor Help. Using the Search dialog box, you
can look up Help information by using keywords.



How to Use Help

Describes how to use Help.



About Domain Monitor

Displays version, mode, and copyright information about Windows NT.



Properties
Displays details about servers and trusted domains for a selected domain. You can also display the

Domain Controller Status dialog box by double-clicking the PDC (Primary Domain Controller) name in
the main Domain Monitor window.






